Minimum requirements to view:
Adobe Flash Player
Internet Explorer users must have Internet Explorer 8 or higher, other browsers are supported as long as the Adobe Flash Player plugin is installed

For support contact:
Swagit
editors@swagit.com
1-800-573-3160